Server | At the moment, the systems may still be slow.

Incident Report for Dyflexis

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 15:37 CEST

Identified

As you may have noticed, the systems are still very slow. We are currently investigating this now.
Our apologies for the inconvenience.
Posted Jul 02, 2025 - 09:38 CEST
This incident affected: Dyflexis Web Application and Dyflexis Mobile App.