At the moment, it fails to send the payroll.

Incident Report for Dyflexis

Resolved

This incident has been resolved.
Posted Mar 27, 2024 - 12:44 CET

Identified

At the moment, we are experiencing problems with sending the remuneration. Our tech department is working hard to resolve this, excuses for the inconvenience
Posted Mar 27, 2024 - 11:48 CET
This incident affected: Dyflexis Web Application.