Our phone lines are currently experiencing some technical issues

Incident Report for Dyflexis

Resolved

This incident has been resolved.
Posted Apr 25, 2024 - 15:03 CEST

Investigating

We are currently investigating this issue.
Posted Apr 25, 2024 - 14:46 CEST

Monitoring

Our Support can is currently unavailable via phone. We kindly ask you to contact us via mail at support@Dyflexis.com in the meantime.
We are resolving this issue as soon as possible.
Posted Apr 25, 2024 - 14:25 CEST
This incident affected: Dyflexis Web Application.