Unfortunately, we are experiencing problems with our telephone system.
Incident Report for Dyflexis
Resolved
This incident has been resolved.
Posted May 30, 2024 - 10:26 CEST
Identified
We are currently experiencing problems with our phone, which is why we are less accessible. If there are any urgent requests, you can always send an e-mail to support@dyflexis.com.
Posted May 30, 2024 - 09:47 CEST
This incident affected: Dyflexis Web Application.