Currently, our support is not available by phone
Incident Report for Dyflexis
Resolved
This incident has been resolved.
Posted Jul 17, 2024 - 09:24 CEST
Update
We are continuing to investigate this issue.
Posted Jul 17, 2024 - 09:24 CEST
Investigating
Our phone system is down, making us unavailable by phone. We are working hard to resolve the issue as soon as possible. You can submit your question via support@dyflexis.com.
Posted Jul 17, 2024 - 09:07 CEST
This incident affected: API.