System is slow or some pages are not loading
Incident Report for Dyflexis
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 15:49 CET
Update
We are continuing to investigate this issue.
Posted Dec 15, 2023 - 15:24 CET
Investigating
We are aware that some users may be experiencing slower system performance or difficulties in loading various pages. Our team is actively investigating the issue to identify and resolve the root cause.
Posted Dec 15, 2023 - 14:36 CET
This incident affected: Dyflexis Web Application.